gnome-extra/gnome-logs: x86 stable wrt bug #717144
[gentoo.git] / gnome-extra / gnome-dvb-daemon / gnome-dvb-daemon-0.2.90-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5 PYTHON_COMPAT=( python3_{6,7} )
6
7 inherit gnome2 python-single-r1
8
9 DESCRIPTION="Setup your DVB devices, record and watch TV shows and browse EPG using GStreamer"
10 HOMEPAGE="https://wiki.gnome.org/Projects/DVBDaemon"
11
12 LICENSE="GPL-3+"
13 SLOT="0"
14 KEYWORDS="amd64"
15 IUSE=""
16 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
17
18 RDEPEND=">=dev-libs/glib-2.32.0:2
19         dev-libs/libgudev:0
20         >=media-libs/gstreamer-1.4.0:1.0
21         >=media-libs/gst-plugins-good-1.4.0:1.0
22         >=media-libs/gst-plugins-bad-1.4.0:1.0
23         >=dev-libs/libgee-0.8:0.8
24         >=dev-db/sqlite-3.4:3
25         >=media-libs/gst-rtsp-server-1.4.5:1.0
26         media-plugins/gst-plugins-dvb:1.0
27         dev-python/gst-python:1.0
28         >=dev-python/pygobject-3.2.1:3
29         >=dev-libs/gobject-introspection-1.44.0:=
30         x11-libs/pango[introspection]
31         x11-libs/gtk+:3[introspection]
32         ${PYTHON_DEPS}"
33 DEPEND="${RDEPEND}
34         >=dev-util/intltool-0.40.0
35         virtual/pkgconfig:0
36         >=sys-devel/gettext-0.18.1
37 "
38
39 src_prepare() {
40         gnome2_src_prepare
41         python_fix_shebang .
42 }
43
44 src_configure() {
45         # Prevent sandbox violations, bug #569992
46         addpredict /dev
47         gnome2_src_configure --disable-totem-plugin
48 }
49
50 src_install() {
51         gnome2_src_install
52         python_optimize
53 }