c6e3a2dadd5ebb9fc4b1ecbda476cdcb878fc717
[gentoo.git] / gnome-extra / gnome-documents / gnome-documents-3.26.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit gnome2
6
7 DESCRIPTION="A document manager application for GNOME"
8 HOMEPAGE="https://wiki.gnome.org/Apps/Documents"
9
10 LICENSE="GPL-2+"
11 SLOT="0"
12 IUSE=""
13 KEYWORDS="~amd64 x86"
14
15 # cairo-1.14 for cairo_surface_set_device_scale check and usage
16 COMMON_DEPEND="
17         >=app-text/evince-3.13.3[introspection]
18         >=net-libs/webkit-gtk-2.6:4[introspection]
19         >=dev-libs/gjs-1.48.0
20         <dev-libs/gjs-1.53
21         >=dev-libs/glib-2.39.3:2
22         >=dev-libs/gobject-introspection-1.31.6:=
23         >=x11-libs/gtk+-3.22.15:3[introspection]
24         >=net-libs/libsoup-2.41.3:2.4
25         gnome-base/gnome-desktop:3=[introspection]
26         >=app-misc/tracker-2:=
27         >=x11-libs/cairo-1.14
28         >=dev-libs/libgdata-0.13.3:=[crypt,gnome-online-accounts,introspection]
29         x11-libs/gdk-pixbuf:2[introspection]
30         >=net-libs/gnome-online-accounts-3.2.0[introspection]
31         x11-libs/pango[introspection]
32         >=net-libs/libzapojit-0.0.2[introspection]
33         >=app-text/libgepub-0.5[introspection]
34         <app-text/libgepub-0.6
35 "
36 RDEPEND="${COMMON_DEPEND}
37         >=app-misc/tracker-miners-2
38         net-misc/gnome-online-miners
39         sys-apps/dbus
40         x11-themes/adwaita-icon-theme
41 "
42 DEPEND="${COMMON_DEPEND}
43         dev-libs/libxslt
44         >=sys-devel/gettext-0.19.8
45         dev-util/itstool
46         virtual/pkgconfig
47 "
48 # eautoreconf requires yelp-tools and autoconf-archive