sys-devel/gcc-config: arm64 stable (bug #711382)
[gentoo.git] / gnome-extra / gnome-contacts / gnome-contacts-3.34.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit gnome.org gnome2-utils meson vala xdg
7
8 DESCRIPTION="GNOME contact management application"
9 HOMEPAGE="https://wiki.gnome.org/Design/Apps/Contacts"
10
11 LICENSE="GPL-2+"
12 SLOT="0"
13 IUSE="telepathy v4l"
14 KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
15
16 VALA_DEPEND="
17         $(vala_depend)
18         >=dev-libs/gobject-introspection-1.54
19         dev-libs/folks[vala(+)]
20         net-libs/gnome-online-accounts[vala]
21         gnome-extra/evolution-data-server[gtk,vala]
22         telepathy? ( net-libs/telepathy-glib[vala] )
23         gui-libs/libhandy:0.0[vala]
24 "
25 # Configure is wrong; it needs cheese-3.5.91, not 3.3.91
26 RDEPEND="
27         >=gnome-extra/evolution-data-server-3.13.90:=[gnome-online-accounts]
28         >=dev-libs/folks-0.11.4:=[eds,telepathy?]
29         >=dev-libs/glib-2.44:2
30         >=dev-libs/libgee-0.10:0.8
31         >=gnome-base/gnome-desktop-3.0:3=
32         net-libs/gnome-online-accounts:=
33         >=x11-libs/gtk+-3.23.1:3
34         v4l? ( >=media-video/cheese-3.5.91:= )
35         telepathy? ( >=net-libs/telepathy-glib-0.22 )
36         >=gui-libs/libhandy-0.0.9:0.0=
37 "
38 DEPEND="${RDEPEND}"
39 BDEPEND="
40         ${VALA_DEPEND}
41         app-text/docbook-xml-dtd:4.2
42         app-text/docbook-xsl-stylesheets
43         dev-libs/appstream-glib
44         dev-libs/libxml2:2
45         dev-libs/libxslt
46         >=sys-devel/gettext-0.19.8
47         virtual/pkgconfig
48 "
49
50 src_prepare() {
51         xdg_src_prepare
52         vala_src_prepare
53 }
54
55 src_configure() {
56         local emesonargs=(
57                 $(meson_use v4l cheese)
58                 $(meson_use telepathy)
59                 -Dmanpage=true
60                 -Ddocs=false
61         )
62         meson_src_configure
63 }
64
65 pkg_postinst() {
66         xdg_pkg_postinst
67         gnome2_schemas_update
68 }
69
70 pkg_postrm() {
71         xdg_pkg_postrm
72         gnome2_schemas_update
73 }