Merge remote-tracking branch 'Vindex17/master'
[gentoo.git] / gnome-extra / gnome-characters / gnome-characters-3.16.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 GCONF_DEBUG="yes"
7 VALA_MIN_API_VERSION="0.16"
8 VALA_USE_DEPEND="vapigen"
9
10 inherit gnome2 vala virtualx
11
12 DESCRIPTION="Unicode character map viewer and library"
13 HOMEPAGE="https://live.gnome.org/Gucharmap"
14
15 LICENSE="GPL-2 BSD"
16 SLOT="0"
17 KEYWORDS="amd64 ~x86"
18 IUSE="test"
19
20 RDEPEND="${COMMON_DEPEND}
21         >=dev-libs/gjs-1.43.3
22         >=dev-libs/glib-2.32:2
23         >=dev-libs/gobject-introspection-1.35.9
24         >=dev-libs/libunistring-0.9.5
25         >=x11-libs/gtk+-3:3[introspection]
26         >=x11-libs/pango-1.36[introspection]
27 "
28 DEPEND="${RDEPEND}
29         dev-libs/appstream-glib
30         >=dev-util/intltool-0.50.1
31         sys-devel/gettext
32         virtual/pkgconfig
33         test? ( dev-util/dogtail )
34 "
35
36 src_configure() {
37         gnome2_src_configure $(use_enable test dogtail)
38 }
39
40 src_test() {
41         Xemake check
42 }