dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / gnome-extra / chrome-gnome-shell / chrome-gnome-shell-10-r3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit cmake-utils python-single-r1
9
10 DESCRIPTION="GNOME Shell integration for Chrome/Chromium, Firefox, Vivaldi, Opera browsers"
11 HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome"
12 SRC_URI="mirror://gnome/sources/${PN}/${PV}/${P}.tar.xz"
13
14 LICENSE="GPL-3+"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
17 IUSE=""
18
19 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
20
21 DEPEND="${PYTHON_DEPS}
22         app-misc/jq
23         sys-apps/coreutils
24 "
25 RDEPEND="${PYTHON_DEPS}
26         $(python_gen_cond_dep '
27                 dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
28                 dev-python/requests[${PYTHON_MULTI_USEDEP}]
29         ')
30         gnome-base/gnome-shell
31 "
32
33 src_configure() {
34         local mycmakeargs=( -DBUILD_EXTENSION=OFF )
35         cmake-utils_src_configure
36 }
37
38 src_install() {
39         cmake-utils_src_install
40
41         if [[ $(get_libdir) != "lib" && "${SYMLINK_LIB}" != yes ]]; then
42                 # Workaround www-client/firefox-bin manifests location
43                 # Bug: https://bugs.gentoo.org/643522
44                 insinto /usr/lib/mozilla/native-messaging-hosts
45                 doins "${ED}"/usr/$(get_libdir)/mozilla/native-messaging-hosts/org.gnome.chrome_gnome_shell.json
46         fi
47 }
48
49 pkg_postinst() {
50         elog "Please note that this package provides native messaging connector only."
51         elog "You can install browser extension using link provided at"
52         elog "https://extensions.gnome.org website."
53 }