e76ac8261411e656d31601a4ec14de1890af96a6
[gentoo.git] / gnome-base / libgtop / libgtop-2.38.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit flag-o-matic gnome2
6
7 DESCRIPTION="A library that provides top functionality to applications"
8 HOMEPAGE="https://git.gnome.org/browse/libgtop"
9
10 LICENSE="GPL-2+"
11 SLOT="2/11" # libgtop soname version
12 KEYWORDS="alpha amd64 arm ~arm64 ~ia64 ~mips ppc ppc64 ~sh sparc x86"
13 IUSE="+introspection"
14
15 RDEPEND="
16         >=dev-libs/glib-2.26:2
17         introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
18 "
19 DEPEND="${RDEPEND}
20         >=dev-util/gtk-doc-am-1.4
21         >=sys-devel/gettext-0.19.4
22         virtual/pkgconfig
23 "
24
25 src_configure() {
26         # Add explicit stdc, bug #628256
27         append-cflags "-std=c99"
28
29         gnome2_src_configure \
30                 --disable-static \
31                 $(use_enable introspection)
32 }