dev-python/cppy: arm64 keyworded (bug #721130)
[gentoo.git] / gnome-base / libgnomeui / libgnomeui-2.24.5-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 GCONF_DEBUG="no"
6 GNOME2_LA_PUNT="yes"
7 GNOME_TARBALL_SUFFIX="bz2"
8
9 inherit gnome2
10
11 DESCRIPTION="User Interface routines for Gnome"
12 HOMEPAGE="https://library.gnome.org/devel/libgnomeui/stable/"
13
14 LICENSE="LGPL-2"
15 SLOT="0"
16 KEYWORDS="~alpha amd64 arm ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 # gtk+-2.14 dep instead of 2.12 ensures system doesn't loose VFS capabilities in GtkFilechooser
21 RDEPEND="
22         dev-libs/atk
23         >=dev-libs/glib-2.16:2
24         >=dev-libs/libxml2-2.4.20:2
25         >=dev-libs/popt-1.5
26         >=gnome-base/gconf-2:2
27         >=gnome-base/gnome-keyring-0.4
28         >=gnome-base/gnome-vfs-2.7.3:2
29         >=gnome-base/libgnome-2.13.7
30         >=gnome-base/libgnomecanvas-2
31         gnome-base/libgnome-keyring
32         >=gnome-base/libbonoboui-2.13.1
33         >=gnome-base/libglade-2:2.0
34         media-libs/libart_lgpl
35         x11-libs/gdk-pixbuf:2
36         >=x11-libs/gtk+-2.14:2
37         >=x11-libs/pango-1.1.2
38         x11-libs/libICE
39         x11-libs/libSM
40 "
41 DEPEND="${RDEPEND}
42         dev-util/gtk-doc-am
43         sys-devel/gettext
44         virtual/pkgconfig
45         >=dev-util/intltool-0.40
46 "
47 PDEPEND="x11-themes/adwaita-icon-theme"
48
49 src_prepare() {
50         if ! use test; then
51                 sed 's/ test-gnome//' -i Makefile.am Makefile.in || die "sed failed"
52         fi
53         gnome2_src_prepare
54 }