gnome-base/gnome-extra-apps: remove old
[gentoo.git] / gnome-base / gsettings-desktop-schemas / gsettings-desktop-schemas-3.32.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit gnome.org gnome2-utils meson xdg
6
7 DESCRIPTION="Collection of GSettings schemas for GNOME desktop"
8 HOMEPAGE="https://git.gnome.org/browse/gsettings-desktop-schemas"
9
10 LICENSE="LGPL-2.1+"
11 SLOT="0"
12 IUSE="+introspection"
13 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
14
15 DEPEND="!<gnome-base/gdm-3.8"
16 RDEPEND="${DEPEND}"
17 BDEPEND="
18         introspection? ( >=dev-libs/gobject-introspection-1.54:= )
19         dev-util/glib-utils
20         >=sys-devel/gettext-0.19.8
21         virtual/pkgconfig
22 "
23
24 PATCHES=(
25         # Revert change to 'Source Code Pro 10' and 'Cantarell 11' fonts back to generic sans and monospace aliases
26         "${FILESDIR}"/${PV}-default-fonts.patch
27 )
28
29 src_configure() {
30         meson_src_configure $(meson_use introspection)
31 }
32
33 pkg_postinst() {
34         xdg_pkg_postinst
35         gnome2_schemas_update
36 }
37
38 pkg_postrm() {
39         xdg_pkg_postrm
40         gnome2_schemas_update
41 }