gnome-base/gnome-core-libs: remove old
[gentoo.git] / gnome-base / gnome-light / gnome-light-3.34.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 P_RELEASE="$(ver_cut 1-2)"
7
8 DESCRIPTION="Meta package for GNOME-Light, merge this package to install"
9 HOMEPAGE="https://www.gnome.org/"
10 LICENSE="metapackage"
11 SLOT="2.0"
12 IUSE="cups +gnome-shell"
13
14 # when unmasking for an arch
15 # double check none of the deps are still masked !
16 KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 x86"
17
18 # XXX: Note to developers:
19 # This is a wrapper for the 'light' GNOME 3 desktop, and should only consist of
20 # the bare minimum of libs/apps needed. It is basically gnome-base/gnome without
21 # any apps, but shouldn't be used by users unless they know what they are doing.
22 # cantarell minimum version is ensured here as gnome-shell depends on it.
23 RDEPEND="
24         >=gnome-base/gnome-core-libs-${PV}[cups?]
25
26         >=gnome-base/gnome-session-3.34.2
27         >=gnome-base/gnome-settings-daemon-3.34.2[cups?]
28         >=gnome-base/gnome-control-center-${PV}[cups?]
29
30         >=gnome-base/nautilus-3.34.2
31
32         gnome-shell? (
33                 >=x11-wm/mutter-${PV}
34                 >=dev-libs/gjs-1.58.5
35                 >=gnome-base/gnome-shell-${PV}
36                 >=media-fonts/cantarell-0.111 )
37
38         >=x11-themes/adwaita-icon-theme-3.32.0
39         >=x11-themes/gnome-themes-standard-3.28
40         >=x11-themes/gnome-backgrounds-${P_RELEASE}
41
42         >=x11-terms/gnome-terminal-3.34.2
43 "
44 # adwaita-icon-theme kept back on purpose due to brokenness without rust librsvg,
45 # in the hope that the old icon package version is good enough for everything too
46 # until librsvg gets updated. This dep should be raised to 3.34 with 3.34.5 meta.
47 DEPEND=""
48 PDEPEND=">=gnome-base/gvfs-1.42.2"
49 BDEPEND=""
50 S="${WORKDIR}"
51
52 pkg_pretend() {
53         if ! use gnome-shell; then
54                 # Users probably want to use gnome-flashback, e16, sawfish, etc
55                 ewarn "You're not installing GNOME Shell"
56                 ewarn "You will have to install and manage a window manager by yourself"
57         fi
58 }
59
60 pkg_postinst() {
61         # Remember people where to find our project information
62         elog "Please remember to look at https://wiki.gentoo.org/wiki/Project:GNOME"
63         elog "for information about the project and documentation."
64 }