gnome-base/gnome-shell: bump to 3.34.5
[gentoo.git] / gnome-base / gnome-light / gnome-light-3.30.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit eapi7-ver
7
8 P_RELEASE="$(ver_cut 1-2)"
9
10 DESCRIPTION="Meta package for GNOME-Light, merge this package to install"
11 HOMEPAGE="https://www.gnome.org/"
12 LICENSE="metapackage"
13 SLOT="2.0"
14 IUSE="cups +gnome-shell"
15
16 # when unmasking for an arch
17 # double check none of the deps are still masked !
18 KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
19
20 # XXX: Note to developers:
21 # This is a wrapper for the 'light' GNOME 3 desktop, and should only consist of
22 # the bare minimum of libs/apps needed. It is basically gnome-base/gnome without
23 # any apps, but shouldn't be used by users unless they know what they are doing.
24 # cantarell minimum version is ensured here as gnome-shell depends on it.
25 RDEPEND="
26         >=gnome-base/gnome-core-libs-${PV}[cups?]
27
28         >=gnome-base/gnome-session-3.30.1
29         >=gnome-base/gnome-settings-daemon-3.30.1.2[cups?]
30         >=gnome-base/gnome-control-center-${PV}[cups?]
31
32         >=gnome-base/nautilus-${PV}
33
34         gnome-shell? (
35                 >=x11-wm/mutter-${PV}
36                 >=dev-libs/gjs-1.54.2
37                 >=gnome-base/gnome-shell-${PV}
38                 >=media-fonts/cantarell-0.111 )
39
40         >=x11-themes/adwaita-icon-theme-${P_RELEASE}
41         >=x11-themes/gnome-themes-standard-3.28
42         >=x11-themes/gnome-backgrounds-${P_RELEASE}
43
44         >=x11-terms/gnome-terminal-${PV}
45 "
46 DEPEND=""
47 PDEPEND=">=gnome-base/gvfs-1.38.1"
48 S="${WORKDIR}"
49
50 pkg_pretend() {
51         if ! use gnome-shell; then
52                 # Users probably want to use e16, sawfish, etc
53                 ewarn "You're not installing GNOME Shell"
54                 ewarn "You will have to install and manage a window manager by yourself"
55         fi
56 }
57
58 pkg_postinst() {
59         # Remember people where to find our project information
60         elog "Please remember to look at https://wiki.gentoo.org/wiki/Project:GNOME"
61         elog "for information about the project and documentation."
62 }