gnome-base/gdm: drop alpha keywords
[gentoo.git] / gnome-base / gnome-extra-apps / gnome-extra-apps-3.34.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Sub-meta package for the applications of GNOME 3"
7 HOMEPAGE="https://www.gnome.org/"
8 LICENSE="metapackage"
9 SLOT="3.0"
10 IUSE="+games share +shotwell +tracker"
11
12 KEYWORDS="amd64 ~arm64 x86"
13
14 # Note to developers:
15 # This is a wrapper for the extra apps integrated with GNOME 3
16 # Keep pkg order within a USE flag as upstream releng versions file
17 # TODO: Should we keep these here: gnome-dictionary, gucharmap, sound-juicer, vinagre, vino; replace gucharmap with gnome-characters?
18 # gnome-documents removed for now, as it didn't find a good place upstream and is getting dropped from default sets for distros for 3.30 (and for 3.26 it required newer tracker than we had at the time)
19 RDEPEND="
20         >=gnome-base/gnome-core-libs-${PV}
21
22         >=sys-apps/baobab-3.34.0
23         >=media-video/cheese-3.34.0
24         >=www-client/epiphany-${PV}
25         >=app-arch/file-roller-3.32.4
26         >=gnome-extra/gnome-calculator-3.34.1
27         >=gnome-extra/gnome-calendar-3.34.2
28         >=gnome-extra/gnome-characters-3.32.1
29         >=sys-apps/gnome-disk-utility-3.34.4
30         >=media-gfx/gnome-font-viewer-3.34.0
31         >=media-gfx/gnome-screenshot-3.34.0
32         >=gnome-extra/gnome-system-monitor-3.32.1
33         >=gnome-extra/gnome-weather-3.34.0
34         >=gnome-extra/gucharmap-12.0.1:2.90
35         >=gnome-extra/sushi-3.34.0
36         >=media-sound/sound-juicer-3.24.0
37         >=net-misc/vino-3.22.0
38
39         >=gnome-base/dconf-editor-3.34.4
40         >=app-dicts/gnome-dictionary-3.26.1
41         >=mail-client/evolution-${PV}
42         >=gnome-extra/gnome-tweaks-3.34.0
43         >=gnome-extra/nautilus-sendto-3.8.6
44         >=net-misc/vinagre-3.22.0
45
46         games? (
47                 >=games-puzzle/five-or-more-3.32.1
48                 >=games-board/four-in-a-row-3.34.4
49                 >=games-board/gnome-chess-3.34.0
50                 >=games-puzzle/gnome-klotski-3.34.4
51                 >=games-board/gnome-mahjongg-3.34.0
52                 >=games-board/gnome-mines-3.34.0
53                 >=games-arcade/gnome-nibbles-3.34.2
54                 >=games-arcade/gnome-robots-3.34.1
55                 >=games-puzzle/gnome-sudoku-3.34.1
56                 >=games-puzzle/gnome-taquin-3.34.4
57                 >=games-puzzle/gnome-tetravex-3.34.4
58                 >=games-puzzle/hitori-3.34.0
59                 >=games-board/iagno-3.34.5
60                 >=games-puzzle/lightsoff-3.34.0
61                 >=games-puzzle/quadrapassel-3.34.1
62                 >=games-puzzle/swell-foop-3.34.1
63                 >=games-board/tali-3.32.1
64         )
65         share? ( >=gnome-extra/gnome-user-share-3.34.0 )
66         shotwell? ( >=media-gfx/shotwell-0.30.8 )
67         tracker? (
68                 >=app-misc/tracker-2.3.1
69                 >=app-misc/tracker-miners-2.3.1
70                 >=media-gfx/gnome-photos-3.34.1
71                 >=media-sound/gnome-music-3.34.4 )
72 "
73 DEPEND=""
74 BDEPEND=""
75 S=${WORKDIR}