207ba8d0a0e6cc3bb6feebf733c9a2943f3bad8f
[gentoo.git] / gnome-base / gnome-core-apps / gnome-core-apps-3.34.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Sub-meta package for the core applications integrated with GNOME 3"
7 HOMEPAGE="https://www.gnome.org/"
8 LICENSE="metapackage"
9 SLOT="3.0"
10 IUSE="+bluetooth cups"
11
12 # when unmasking for an arch
13 # double check none of the deps are still masked !
14 KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
15
16 # gnome-color-manager min version enforced here due to control-center pulling it in
17 RDEPEND="
18         >=gnome-base/gnome-core-libs-${PV}[cups?]
19
20         >=gnome-base/gnome-session-3.32.0
21         >=gnome-base/gnome-settings-daemon-3.34.2[cups?]
22         >=gnome-base/gnome-control-center-3.34.4[cups?]
23         >=gnome-extra/gnome-color-manager-3.32.0
24
25         >=app-crypt/gcr-3.34.0
26         >=gnome-base/nautilus-3.34.2
27         >=gnome-base/gnome-keyring-3.34.0
28         >=gnome-extra/evolution-data-server-${PV}
29
30         >=app-crypt/seahorse-3.32.2
31         >=app-editors/gedit-3.34.1
32         >=app-text/evince-3.34.2
33         >=gnome-extra/gnome-contacts-3.34.1
34         >=media-gfx/eog-3.32.1
35         >=media-video/totem-3.34.1
36         >=x11-terms/gnome-terminal-3.34.2
37
38         >=gnome-extra/gnome-user-docs-3.34.1
39         >=gnome-extra/yelp-3.34.0
40
41         >=x11-themes/adwaita-icon-theme-3.32.0
42
43         bluetooth? ( >=net-wireless/gnome-bluetooth-3.34.0 )
44 "
45 DEPEND=""
46 BDEPEND=""
47
48 # cdr? ( >=app-cdr/brasero-3.12.2 ) # not part of gnome releng release anymore
49 # >=gnome-base/gnome-menus-3.13.3:3  # not used by core gnome anymore, just gnome-classic extensions
50 # >=net-im/empathy-3.12.12 # not part of gnome releng core or apps suite anymore
51 # eog kept back due to rust librsvg req
52 # adwaita-icon-theme kept back due to visual corruption when build with non-rust librsvg
53
54 S="${WORKDIR}"