gnome-base/gnome-core-apps: x86 stable wrt bug #551826
[gentoo.git] / gnome-base / gnome-core-apps / gnome-core-apps-3.14.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 DESCRIPTION="Sub-meta package for the core applications integrated with GNOME 3"
8 HOMEPAGE="https://www.gnome.org/"
9 LICENSE="metapackage"
10 SLOT="3.0"
11 IUSE="+bluetooth +cdr cups"
12
13 # when unmasking for an arch
14 # double check none of the deps are still masked !
15 KEYWORDS="amd64 ~arm ~ia64 ~ppc ~ppc64 x86"
16
17 # Note to developers:
18 # This is a wrapper for the core apps tightly integrated with GNOME 3
19 # gtk-engines:2 is still around because it's needed for gtk2 apps
20 RDEPEND="
21         >=gnome-base/gnome-core-libs-${PV}[cups?]
22
23         >=gnome-base/gnome-session-${PV}
24         >=gnome-base/gnome-menus-3.10.1:3
25         >=gnome-base/gnome-settings-daemon-${PV}[cups?]
26         >=gnome-base/gnome-control-center-${PV}[cups?]
27
28         >=app-crypt/gcr-${PV}
29         >=gnome-base/nautilus-${PV}
30         >=gnome-base/gnome-keyring-${PV}
31         >=gnome-extra/evolution-data-server-3.12.9
32
33         >=app-crypt/seahorse-${PV}
34         >=app-editors/gedit-${PV}
35         >=app-text/evince-${PV}
36         >=gnome-extra/gnome-contacts-${PV}
37         >=media-gfx/eog-${PV}
38         >=media-video/totem-${PV}
39         >=net-im/empathy-3.12.7
40         >=x11-terms/gnome-terminal-${PV}
41
42         >=gnome-extra/gnome-user-docs-${PV}
43         >=gnome-extra/yelp-${PV}
44
45         >=x11-themes/adwaita-icon-theme-${PV}
46         >=x11-themes/gnome-themes-standard-${PV}
47
48         bluetooth? ( >=net-wireless/gnome-bluetooth-${PV} )
49         cdr? ( >=app-cdr/brasero-3.12.0 )
50
51         !gnome-base/gnome-applets
52 "
53 DEPEND=""
54
55 S="${WORKDIR}"