Merge github#363: sys-process/atop: add systemd support
[gentoo.git] / gnome-base / gnome / gnome-3.16.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 DESCRIPTION="Meta package for GNOME 3, merge this package to install"
8 HOMEPAGE="https://www.gnome.org/"
9
10 LICENSE="metapackage"
11 SLOT="2.0" # Cannot be installed at the same time as gnome-2
12
13 # when unmasking for an arch
14 # double check none of the deps are still masked !
15 KEYWORDS="amd64 ~arm ~ia64 ~ppc ~ppc64 x86"
16
17 IUSE="accessibility +bluetooth +classic +cdr cups +extras"
18
19 S=${WORKDIR}
20
21 # TODO: check accessibility completeness
22 # GDM-3.0 integrates very nicely with GNOME Shell
23 RDEPEND="
24         >=gnome-base/gnome-core-libs-${PV}[cups?]
25         >=gnome-base/gnome-core-apps-${PV}[cups?,bluetooth?,cdr?]
26
27         >=gnome-base/gdm-${PV}
28
29         >=x11-wm/mutter-${PV}
30         >=gnome-base/gnome-shell-${PV}[bluetooth?]
31
32         >=x11-themes/gnome-backgrounds-${PV}
33         x11-themes/sound-theme-freedesktop
34
35         accessibility? (
36                 >=app-accessibility/at-spi2-atk-2.16
37                 >=app-accessibility/at-spi2-core-2.16
38                 >=app-accessibility/caribou-0.4.18
39                 >=app-accessibility/orca-${PV}
40                 >=gnome-extra/mousetweaks-3.12.0 )
41         classic? ( >=gnome-extra/gnome-shell-extensions-${PV} )
42         extras? ( >=gnome-base/gnome-extra-apps-${PV} )
43 "
44
45 DEPEND=""
46
47 PDEPEND=">=gnome-base/gvfs-1.24[udisks]"
48
49 pkg_postinst() {
50         # Remember people where to find our project information
51         elog "Please remember to look at https://wiki.gentoo.org/wiki/Project:GNOME"
52         elog "for information about the project and documentation."
53 }