Use https by default
[gentoo.git] / games-util / wit / wit-2.30a.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="A set of command line tools to manipulate Wii/GameCube ISO images and WBFS containers"
10 HOMEPAGE="http://wit.wiimm.de/"
11 SRC_URI="https://dev.gentoo.org/~radhermit/distfiles/${P}.tar.xz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="+fuse +zlib"
17
18 RDEPEND="
19         app-arch/bzip2
20         fuse? ( sys-fs/fuse )
21         zlib? ( sys-libs/zlib )
22 "
23 DEPEND="${RDEPEND}"
24
25 DOCS="doc/*.txt"
26
27 src_prepare() {
28         epatch "${FILESDIR}"/${P}-makefile.patch
29         epatch "${FILESDIR}"/${P}-no-exec-stack.patch
30         epatch "${FILESDIR}"/${P}-sizeof-pointer-memaccess.patch
31 }
32
33 src_compile() {
34         export NO_FUSE=$(usex fuse 0 1)
35         export NO_ZLIB=$(usex zlib 0 1)
36
37         emake INSTALL_PATH="${D}"/usr CC="$(tc-getCC)"
38         emake doc
39 }