dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / games-util / springlobby / springlobby-0.267.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 WX_GTK_VER="3.0"
7 inherit cmake-utils gnome2-utils wxwidgets
8
9 DESCRIPTION="The official lobby client for SpringRTS community games"
10 HOMEPAGE="https://springlobby.info"
11 SRC_URI="https://www.springlobby.info/tarballs/${P}.tar.bz2"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="debug +libnotify +nls +sound"
17
18 RDEPEND="
19         >=dev-libs/boost-1.35:=
20         dev-libs/openssl:0=
21         net-misc/curl
22         sys-libs/zlib[minizip]
23         x11-libs/libICE
24         x11-libs/libSM
25         x11-libs/libXext
26         x11-libs/wxGTK:${WX_GTK_VER}[X]
27         libnotify? ( x11-libs/libnotify )
28         sound? ( media-libs/alure
29                 media-libs/openal
30         )
31 "
32
33 DEPEND="${RDEPEND}
34         nls? ( sys-devel/gettext )
35 "
36
37 src_configure() {
38         setup-wxwidgets
39         local mycmakeargs=(
40                 -DOPTION_NOTIFY=$(usex libnotify)
41                 -DOPTION_SOUND=$(usex sound)
42                 -DOPTION_TRANSLATION_SUPPORT=$(usex nls)
43                 -DAUX_VERSION="(Gentoo,${ARCH})"
44                 )
45         cmake-utils_src_configure
46 }
47
48 pkg_postinst() {
49         gnome2_icon_cache_update
50 }
51
52 pkg_postrm() {
53         gnome2_icon_cache_update
54 }