dev-db/mysql: ppc/ppc64 stable wrt bug #658822
[gentoo.git] / games-util / qstat / qstat-2.14.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="Server statics collector supporting many FPS games"
9 HOMEPAGE="https://github.com/multiplay/qstat"
10 SRC_URI="https://github.com/multiplay/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Artistic"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
15 IUSE="debug"
16
17 DEPEND="!sys-cluster/torque"
18
19 DOCS=( CHANGES.txt COMPILE.txt template/README.txt )
20
21 src_prepare() {
22         default
23         eautoreconf
24
25         # bug #530952
26         sed -i -e 's/strndup/l_strndup/g' qstat.c || die
27 }
28
29 src_configure() {
30         econf $(use_enable debug)
31 }
32
33 src_install() {
34         default
35         dosym qstat /usr/bin/quakestat
36         docinto html
37         dodoc template/*.html qstatdoc.html
38 }