dev-python/numpydoc: arm64 keyworded (bug #721130)
[gentoo.git] / games-util / qstat / qstat-2.11.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 DESCRIPTION="Server statics collector supporting many FPS games"
6 HOMEPAGE="https://sourceforge.net/projects/qstat/"
7 SRC_URI="mirror://sourceforge/qstat/${P}.tar.gz"
8
9 LICENSE="Artistic"
10 SLOT="0"
11 KEYWORDS="~alpha amd64 ~arm hppa ppc64 x86"
12 IUSE="debug"
13
14 DEPEND="!sys-cluster/torque"
15
16 src_prepare() {
17         # bug #530952
18         sed -i -e 's/strndup/l_strndup/g' qstat.c || die
19 }
20
21 src_configure() {
22         econf $(use_enable debug)
23 }
24
25 src_install() {
26         DOCS="CHANGES.txt COMPILE.txt template/README.txt" default
27         dosym qstat /usr/bin/quakestat
28         dohtml template/*.html qstatdoc.html
29 }