virtual/perl-ExtUtils-ParseXS: s390 stable wrt bug #698542
[gentoo.git] / games-util / pogo-manager-bin / pogo-manager-bin-0.1.7.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PN="${PN/-bin}"
7
8 DESCRIPTION="Pokemon Go manager"
9 HOMEPAGE="https://github.com/Wolfsblvt/BlossomsPokemonGoManager"
10 SRC_URI="https://github.com/Wolfsblvt/BlossomsPokemonGoManager/releases/download/v${PV}/BPGM_v${PV}.zip -> ${P}.zip"
11
12 LICENSE="CC-BY-NC-SA-4.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND="|| ( dev-java/oracle-jdk-bin:1.8[javafx] dev-java/oracle-jre-bin:1.8[javafx] )"
18 DEPEND="app-arch/unzip"
19
20 S="${WORKDIR}/BPGM_v${PV}"
21
22 src_install()
23 {
24         insinto /opt/${MY_PN}
25         newins BlossomsPogoManager.jar ${MY_PN}.jar
26
27         dobin "${FILESDIR}/pogo-manager"
28 }
29
30 pkg_postinst()
31 {
32         ewarn "Use of this tool is not sanctioned by Niantic and could get you banned."
33         ewarn "You have been warned!"
34 }