4a5186fae685e779ec5a6efc578a44df4d35c120
[gentoo.git] / games-util / mcrcon / mcrcon-0.6.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Remote connection client for Minecraft servers"
9 HOMEPAGE="https://github.com/Tiiffi/mcrcon"
10 SRC_URI="https://github.com/Tiiffi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11 LICENSE="ZLIB"
12 SLOT="0"
13 KEYWORDS="~amd64 ~arm"
14
15 src_compile() {
16         emake \
17                 CC="$(tc-getCC)" \
18                 CFLAGS="${CFLAGS} ${LDFLAGS} -std=gnu99 -Wall -Wextra -Wpedantic"
19 }
20
21 src_install() {
22         emake install PREFIX="${ED}/usr"
23 }