sci-chemistry/ghemical: Drop old
[gentoo.git] / games-util / joystick / joystick-1.5.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils toolchain-funcs
6
7 MY_P="linuxconsoletools-${PV}"
8 DESCRIPTION="joystick testing utilities"
9 HOMEPAGE="https://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
10 SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ~ppc x86"
15 IUSE="sdl udev"
16
17 DEPEND="sdl? ( media-libs/libsdl:0[video] )
18         !<x11-libs/tslib-1.0-r2"
19 RDEPEND="${DEPEND}
20         udev? ( virtual/udev )"
21
22 S=${WORKDIR}/${MY_P}
23
24 PATCHES=(
25         "${FILESDIR}"/${PN}-1.5.1-build.patch
26         "${FILESDIR}"/${PN}-1.4.8-udev.patch
27 )
28
29 src_prepare() {
30         default
31
32         export PREFIX=/usr
33         tc-export CC PKG_CONFIG
34         export USE_SDL=$(usex sdl)
35 }
36
37 src_install() {
38         default
39         if use !udev ; then
40                 rm "${D}"/usr/bin/jscal-{re,}store || die
41         fi
42 }