dev-ada/gnatcoll-db: PythonMissingDeps and PythonMissingRequiredUSE
[gentoo.git] / games-util / higan-purify / higan-purify-03.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils multilib toolchain-funcs
7
8 MY_P=purify_v${PV}-source
9
10 DESCRIPTION="Rom purifier for higan"
11 HOMEPAGE="http://byuu.org/higan/"
12 SRC_URI="https://higan.googlecode.com/files/${MY_P}.tar.xz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 RDEPEND="
20         dev-games/higan-ananke
21         x11-libs/gtk+:2
22         x11-libs/libX11"
23 DEPEND="${RDEPEND}
24         virtual/pkgconfig"
25
26 S="${WORKDIR}"/${MY_P}/purify
27
28 src_prepare() {
29         epatch "${FILESDIR}"/${P}-QA.patch
30         sed -i \
31                 -e "/handle/s#/usr/local/lib#/usr/$(get_libdir)#" \
32                 nall/dl.hpp || die
33 }
34
35 src_compile() {
36         emake \
37                 platform="x" \
38                 compiler="$(tc-getCXX)" \
39                 phoenix="gtk"
40 }
41
42 src_install() {
43         dobin purify
44 }