games-util/umodpack: Fixes for new Perl, drop broken GUI, EAPI 7
[gentoo.git] / games-util / gamepick / gamepick-0.35-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils
6
7 DESCRIPTION="Launch opengl games with custom graphic settings"
8 HOMEPAGE="http://www.rillion.net/gamepick/index.html"
9 SRC_URI="http://www.rillion.net/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="x11-libs/gtk+:2"
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig"
19
20 src_prepare() {
21         default
22         sed -i \
23                 -e 's/-O2//' \
24                 src/Makefile.in || die
25 }
26
27 src_install() {
28         default
29         newicon ${PN}-48x48.xpm ${PN}.xpm
30         make_desktop_entry ${PN} ${PN}
31 }