dev-lang/rust-bin: drop 1.36.0
[gentoo.git] / games-util / dfarc / dfarc-3.12-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 WX_GTK_VER="3.0"
6 inherit eutils gnome2-utils wxwidgets xdg
7
8 DESCRIPTION="Frontend and .dmod installer for GNU FreeDink"
9 HOMEPAGE="http://www.freedink.org/"
10 SRC_URI="mirror://gnu/freedink/${P}.tar.gz"
11
12 LICENSE="GPL-3 BZIP2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="nls"
16
17 RDEPEND="
18         app-arch/bzip2
19         x11-misc/xdg-utils
20         x11-libs/wxGTK:${WX_GTK_VER}[X]
21 "
22 DEPEND="${RDEPEND}
23         nls? ( >=dev-util/intltool-0.31 )
24 "
25
26 PATCHES=( "${FILESDIR}"/${P}-nowindres.patch )
27
28 src_configure() {
29         econf \
30                 $(use_enable nls) \
31                 --disable-desktopfiles
32 }
33
34 src_install() {
35         default
36         dodoc TRANSLATIONS.txt
37 }
38
39 pkg_preinst() {
40         xdg_pkg_preinst
41         gnome2_icon_savelist
42 }
43
44 pkg_postinst() {
45         xdg_pkg_postinst
46         gnome2_icon_cache_update
47 }
48
49 pkg_postrm() {
50         xdg_pkg_postrm
51         gnome2_icon_cache_update
52 }