app-misc/screen: Use slot operators for ncurses
[gentoo.git] / games-util / dfarc / dfarc-3.10.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 WX_GTK_VER="2.8"
8 inherit gnome2-utils fdo-mime wxwidgets games
9
10 DESCRIPTION="Frontend and .dmod installer for GNU FreeDink"
11 HOMEPAGE="http://www.freedink.org/"
12 SRC_URI="mirror://gnu/freedink/${P}.tar.gz"
13
14 LICENSE="GPL-3 BZIP2"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="nls"
18
19 RDEPEND="
20         app-arch/bzip2
21         x11-misc/xdg-utils
22         x11-libs/wxGTK:${WX_GTK_VER}"
23 DEPEND="${RDEPEND}
24         nls? ( >=dev-util/intltool-0.31 )"
25
26 src_prepare() {
27         sed -i \
28                 -e 's#^datarootdir =.*$#datarootdir = /usr/share#' \
29                 share/Makefile.in || die
30 }
31
32 src_configure() {
33         egamesconf \
34                 $(use_enable nls) \
35                 --disable-desktopfiles
36 }
37
38 src_install() {
39         default
40         dodoc TRANSLATIONS.txt
41         prepgamesdirs
42 }
43
44 pkg_preinst() {
45         games_pkg_preinst
46         gnome2_icon_savelist
47 }
48
49 pkg_postinst() {
50         games_pkg_postinst
51         gnome2_icon_cache_update
52         fdo-mime_desktop_database_update
53         fdo-mime_mime_database_update
54 }
55
56 pkg_postrm() {
57         gnome2_icon_cache_update
58         fdo-mime_desktop_database_update
59         fdo-mime_mime_database_update
60 }