games-strategy/colobot-data: Take over as maintainer
[gentoo.git] / games-strategy / xbattleai / xbattleai-1.2.2-r2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils
6
7 DESCRIPTION="A multi-player game of strategy and coordination"
8 HOMEPAGE="https://inf.ug.edu.pl/~piotao/xbattle/mirror/www.lysator.liu.se/XBattleAI/"
9 SRC_URI="https://inf.ug.edu.pl/~piotao/xbattle/mirror/www.lysator.liu.se/XBattleAI/${P}.tgz"
10
11 LICENSE="xbattle"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 # Since this uses similar code and the same binary name as the original XBattle,
17 # we want to make sure you can't install both at the same time
18 RDEPEND="
19         dev-lang/tcl:0
20         dev-lang/tk:0
21         x11-libs/libX11
22         x11-libs/libXext
23         !games-strategy/xbattle"
24 DEPEND="${RDEPEND}
25         app-text/rman
26         x11-misc/imake
27         x11-base/xorg-proto"
28
29 PATCHES=(
30         "${FILESDIR}"/${P}-sandbox.patch
31 )
32
33 src_prepare() {
34         default
35         rm -f xbcs/foo.xbc~ || die
36 }
37
38 src_install() {
39         DOCS="CONTRIBUTORS README README.AI TODO xbattle.dot" \
40                 default
41         mv "${D}/usr/bin/"{,xb_}gauntletCampaign || die
42 }