Add missing remote-id type=sourceforge
[gentoo.git] / games-strategy / wargus-data / wargus-data-0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit cdrom games
8
9 DESCRIPTION="Warcraft II data for wargus (needs DOS CD)"
10 HOMEPAGE="http://wargus.sourceforge.net/"
11 SRC_URI=""
12
13 LICENSE="all-rights-reserved"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE=""
17
18 DEPEND="${RDEPEND}
19         media-sound/cdparanoia
20         media-sound/timidity++
21         media-video/ffmpeg2theora"
22 # wrt bug #419331
23 RESTRICT="userpriv"
24
25 S=${WORKDIR}
26
27 src_prepare() {
28         export CDROM_NAME="WARCRAFT2"
29         cdrom_get_cds data/rezdat.war
30 }
31
32 src_compile() {
33         # cdparanoia needs write acces to the cdrom device
34         # this fixes sandbox violation wrt #418051
35         local save_sandbox_write=${SANDBOX_WRITE}
36         addwrite /dev
37         "${GAMES_BINDIR}"/wartool -m -v -r "${CDROM_ROOT}"/data "${S}"/ || die
38         SANDBOX_WRITE=${save_sandbox_write}
39 }
40
41 src_install() {
42         insinto "${GAMES_DATADIR}"/stratagus/wargus
43         doins -r *
44         prepgamesdirs
45 }