games-strategy/s25rttr: fix QA issues
[gentoo.git] / games-strategy / seven-kingdoms / seven-kingdoms-2.14.7.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit eutils
7
8 MY_PN="7kaa"
9 MY_P="${MY_PN}-${PV}"
10
11 DESCRIPTION="Seven Kingdoms: Ancient Adversaries"
12 HOMEPAGE="https://7kfans.com/"
13 SRC_URI="https://github.com/the3dfxdude/${MY_PN}/releases/download/v${PV}/${MY_P}.tar.xz
14         https://dev.gentoo.org/~pinkbyte/distfiles/${MY_PN}.png"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="amd64 x86"
19
20 DEPEND="net-libs/enet:1.3=
21         media-libs/libsdl2[X,video]
22         media-libs/openal
23         net-misc/curl"
24 RDEPEND="${DEPEND}"
25
26 S="${WORKDIR}/${MY_P}"
27
28 src_unpack() {
29         unpack ${MY_P}.tar.xz
30 }
31
32 src_install() {
33         default
34
35         doicon "${DISTDIR}/${MY_PN}.png"
36         make_desktop_entry "${MY_PN}" "Seven Kingdoms: Ancient Adversaries" "${MY_PN}" "Game;StrategyGame"
37 }