Use https by default
[gentoo.git] / games-strategy / seven-kingdoms / seven-kingdoms-2.14.5.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils games
8
9 MY_PN="7kaa"
10 MY_P="${MY_PN}-${PV}"
11
12 DESCRIPTION="Seven Kingdoms: Ancient Adversaries"
13 HOMEPAGE="http://7kfans.com/"
14 SRC_URI="mirror://sourceforge/skfans/${MY_PN}-${PV}.tar.xz
15         https://dev.gentoo.org/~pinkbyte/distfiles/${MY_PN}.png"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20
21 DEPEND="net-libs/enet:1.3=
22         media-libs/libsdl2[X,video]
23         media-libs/openal
24         !games-strategy/seven-kingdoms-data"
25 RDEPEND="${DEPEND}"
26
27 S="${WORKDIR}/${MY_P}"
28
29 DOCS=( README )
30
31 src_unpack() {
32         unpack ${MY_PN}-${PV}.tar.xz
33 }
34
35 src_prepare() {
36         epatch_user
37 }
38
39 src_configure() {
40         # In current state debugging works only on Windows :-/
41         egamesconf \
42                 --disable-debug \
43                 --without-wine \
44                 --datadir="${GAMES_DATADIR}/${MY_PN}"
45 }
46
47 src_install() {
48         default
49
50         newgamesbin "src/client/${MY_PN}" "${MY_PN}.bin"
51         doicon "${DISTDIR}/${MY_PN}.png"
52         games_make_wrapper "${MY_PN}" "${GAMES_BINDIR}/${MY_PN}.bin" "${GAMES_DATADIR}/${MY_PN}"
53         make_desktop_entry "${MY_PN}" "Seven Kingdoms: Ancient Adversaries" "${MY_PN}" "Game;StrategyGame"
54
55         prepgamesdirs
56 }