games-strategy/s25rttr: Add missing RESTRICT
[gentoo.git] / games-strategy / maxr / maxr-0.2.9.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit cmake-utils desktop gnome2-utils
7
8 DESCRIPTION="Mechanized Assault and Exploration Reloaded"
9 HOMEPAGE="https://www.maxr.org"
10 SRC_URI="https://www.maxr.org/downloads/${P}.tar.gz"
11
12 LICENSE="GPL-2 FDL-1.2+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="dedicated"
16
17 RDEPEND="media-libs/libsdl2[video]
18         media-libs/sdl2-mixer[vorbis]
19         media-libs/sdl2-net"
20 DEPEND="${RDEPEND}"
21
22 src_configure() {
23         mycmakeargs=(
24                 -DMAXR_BUILD_DEDICATED_SERVER=$(usex dedicated)
25                 -DCMAKE_BUILD_TYPE=Release
26         )
27
28         cmake-utils_src_configure
29 }
30
31 src_install() {
32         cmake-utils_src_install
33         doicon -s 128 data/${PN}.png
34         make_desktop_entry ${PN} "Mechanized Assault and Exploration Reloaded"
35 }
36
37 pkg_preinst() { gnome2_icon_savelist; }
38 pkg_postinst() { gnome2_icon_cache_update; }
39 pkg_postrm() { gnome2_icon_cache_update; }