games-strategy/gwp: Remove last-rited pkg
[gentoo.git] / games-strategy / galaxyhack / galaxyhack-1.74-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils flag-o-matic readme.gentoo-r1
6
7 DESCRIPTION="Multiplayer AI script based strategy game"
8 HOMEPAGE="http://galaxyhack.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
10         mirror://gentoo/${PN}.png"
11
12 LICENSE="GPL-2 galaxyhack"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND="
18         media-libs/libsdl[video]
19         media-libs/sdl-image[png]
20         media-libs/sdl-mixer[mod,vorbis]
21         >=dev-libs/boost-1.34
22 "
23 RDEPEND="${DEPEND}"
24
25 S="${WORKDIR}/${PN}/src"
26
27 DISABLE_AUTOFORMATTING="yes"
28 DOC_CONTENTS="
29 Settings will default to those found in
30 /usr/share/galaxyhack/settings.dat
31 Per user settings can be specified by creating
32 ~/.galaxyhack/settings.dat
33
34 Additional user submitted fleets can be downloaded from
35 http://galaxyhack.sourceforge.net/viewfleets.php
36 "
37
38 src_prepare() {
39         default
40         edos2unix Makefile
41         eapply \
42                 "${FILESDIR}"/${P}-destdirs.patch \
43                 "${FILESDIR}"/${P}-boost.patch \
44                 "${FILESDIR}"/${P}-gcc43.patch \
45                 "${FILESDIR}"/${P}-boost-1.50.patch \
46                 "${FILESDIR}"/${P}-format.patch \
47                 "${FILESDIR}"/${P}-gentoo.patch
48         sed -i "s:@GAMES_DATADIR@:/usr/share:" \
49                 Main.cpp || die
50         sed -i "/Base data path/s:pwd:/usr/share/${PN}:" \
51                 ../settings.dat || die
52 }
53
54 src_install() {
55         dobin "${PN}"
56         cd ..
57         insinto /usr/share/${PN}
58         doins -r fleets gamedata graphics music standardpictures \
59                 settings.dat
60         dodoc readme.txt
61         readme.gentoo_create_doc
62         doicon "${DISTDIR}"/${PN}.png
63         make_desktop_entry ${PN} GalaxyHack
64 }
65
66 pkg_postinst() {
67         readme.gentoo_print_elog
68 }