games-strategy/colobot: Remove redundant version
[gentoo.git] / games-strategy / darwinia-demo / darwinia-demo-1.3.0-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils unpacker
6
7 DESCRIPTION="Darwinia, the hyped indie game of the year. By the Uplink creators"
8 HOMEPAGE="http://www.darwinia.co.uk/downloads/demo_linux.html"
9 SRC_URI="http://www.introversion.co.uk/darwinia/downloads/${PN}2-${PV}.sh"
10
11 LICENSE="Introversion"
12 SLOT="0"
13 KEYWORDS="-* ~amd64 ~x86"
14 IUSE=""
15 RESTRICT="bindist mirror strip"
16
17 RDEPEND="
18         media-libs/libsdl[abi_x86_32(-)]
19         media-libs/libvorbis[abi_x86_32(-)]
20         virtual/glu[abi_x86_32(-)]
21         ~virtual/libstdc++-3.3
22         virtual/opengl[abi_x86_32(-)]"
23
24 S=${WORKDIR}
25
26 dir="/opt/${PN}"
27
28 src_unpack() {
29         unpack_makeself
30 }
31
32 src_install() {
33         exeinto "${dir}/lib"
34         insinto "${dir}/lib"
35
36         doexe lib/{darwinia.bin.x86,open-www.sh}
37         doins lib/{sounds,main,language}.dat
38
39         insinto "${dir}"
40         dodoc README
41
42         exeinto "${dir}"
43         doexe bin/Linux/x86/darwinia
44
45         make_wrapper darwinia-demo ./darwinia "${dir}" "${dir}"
46         newicon darwinian.png ${PN}.png
47         make_desktop_entry darwinia-demo "Darwinia (Demo)"
48 }