dev-python/repoze-lru: keyworded 0.7-r1 for ia64, bug #717946
[gentoo.git] / games-roguelike / powder / powder-117-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit flag-o-matic
6
7 MY_P=${P/-/}_src
8
9 DESCRIPTION="A game in the genre of Rogue, Nethack, and Diablo. Emphasis is on tactical play"
10 HOMEPAGE="http://www.zincland.com/powder/"
11 SRC_URI="http://www.zincland.com/powder/release/${MY_P}.tar.gz"
12
13 LICENSE="CC-Sampling-Plus-1.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="media-libs/libsdl[video]"
19 RDEPEND=${DEPEND}
20
21 S=${WORKDIR}/${MY_P}
22
23 PATCHES=( "${FILESDIR}"/${PN}-117-gcc6.patch )
24
25 src_compile() {
26         append-cxxflags -DCHANGE_WORK_DIRECTORY
27         emake -C port/linux premake
28         emake -C port/linux powder
29 }
30
31 src_install() {
32         dobin port/linux/${PN}
33         dodoc README.TXT CREDITS.TXT
34 }
35
36 pkg_postinst() {
37         elog "While the highscore is kept, save games are never preserved between"
38         elog "versions. Please wait until your current character dies before upgrading."
39 }