dev-qt/qtopengl: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / games-puzzle / tanglet / tanglet-1.5.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit qmake-utils xdg
7
8 DESCRIPTION="Single player word finding game based on Boggle"
9 HOMEPAGE="https://gottcode.org/tanglet/"
10 SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 BDEPEND="
18         dev-qt/linguist-tools:5
19 "
20 DEPEND="
21         dev-qt/qtcore:5
22         dev-qt/qtgui:5
23         dev-qt/qtwidgets:5
24         sys-libs/zlib
25 "
26 RDEPEND="${DEPEND}"
27
28 PATCHES=( "${FILESDIR}"/${PN}-1.5.2-gentoo.patch )
29
30 src_configure() {
31         eqmake5 tanglet.pro
32 }
33
34 src_install() {
35         emake INSTALL_ROOT="${D}" install
36         einstalldocs
37 }