games-puzzle/hitori: amd64 stable wrt bug #702260
[gentoo.git] / games-puzzle / hitori / hitori-3.34.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit gnome.org gnome2-utils meson xdg
6
7 DESCRIPTION="Logic puzzle game for GNOME"
8 HOMEPAGE="https://wiki.gnome.org/Apps/Hitori"
9
10 LICENSE="GPL-3+ CC-BY-SA-3.0"
11 SLOT="0"
12 KEYWORDS="amd64 ~arm ~arm64 ~x86"
13 IUSE=""
14
15 # gtk+-3.22 for build-time optional gtk_show_uri_on_window usage
16 RDEPEND="
17         >=dev-libs/glib-2.32:2
18         >=x11-libs/gtk+-3.22.0:3
19         >=x11-libs/cairo-1.4
20 "
21 DEPEND="${RDEPEND}
22         dev-libs/appstream-glib
23         dev-util/itstool
24         >=sys-devel/gettext-0.19.8
25         virtual/pkgconfig
26 "
27
28 pkg_postinst() {
29         xdg_pkg_postinst
30         gnome2_schemas_update
31 }
32
33 pkg_postrm() {
34         xdg_pkg_postrm
35         gnome2_schemas_update
36 }