games-puzzle/gottet: updated DESCRIPTION and copyright year
[gentoo.git] / games-puzzle / gottet / gottet-1.1.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit gnome2-utils qmake-utils
7
8 DESCRIPTION="A tetris clone based on Qt5"
9 HOMEPAGE="https://gottcode.org/gottet/"
10 SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
11
12 LICENSE="GPL-3+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND="
18         dev-qt/qtcore:5
19         dev-qt/qtgui:5
20         dev-qt/qtwidgets:5
21 "
22 DEPEND="${RDEPEND}
23         dev-qt/linguist-tools:5
24 "
25
26 src_configure() {
27         eqmake5 PREFIX="/usr"
28 }
29
30 src_install() {
31         emake INSTALL_ROOT="${D}" install
32 }
33
34 pkg_preinst() {
35         gnome2_icon_savelist
36 }
37
38 pkg_postinst() {
39         gnome2_icon_cache_update
40 }
41
42 pkg_postrm() {
43         gnome2_icon_cache_update
44 }