games-puzzle/gottet: version bump
[gentoo.git] / games-puzzle / gottet / gottet-1.1.3.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 inherit gnome2-utils qmake-utils
8
9 DESCRIPTION="A tetris clone based on Qt4"
10 HOMEPAGE="https://gottcode.org/gottet/"
11 SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
12
13 LICENSE="GPL-3+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="
19         dev-qt/qtcore:5
20         dev-qt/qtgui:5
21         dev-qt/qtwidgets:5
22 "
23 DEPEND="${RDEPEND}
24         dev-qt/linguist-tools:5
25 "
26
27 src_configure() {
28         eqmake5 PREFIX="/usr"
29 }
30
31 src_install() {
32         emake INSTALL_ROOT="${D}" install
33 }
34
35 pkg_preinst() {
36         gnome2_icon_savelist
37 }
38
39 pkg_postinst() {
40         gnome2_icon_cache_update
41 }
42
43 pkg_postrm() {
44         gnome2_icon_cache_update
45 }