dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / games-puzzle / gnome-taquin / gnome-taquin-3.34.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit gnome.org gnome2-utils meson vala xdg
7
8 DESCRIPTION="Move tiles so that they reach their places"
9 HOMEPAGE="https://wiki.gnome.org/Apps/Taquin"
10
11 LICENSE="GPL-3+ CC-BY-SA-3.0 CC-BY-SA-4.0"
12 SLOT="0"
13 KEYWORDS="amd64 ~arm64 x86"
14 IUSE=""
15
16 RDEPEND="
17         >=dev-libs/glib-2.40.0:2
18         >=media-libs/gsound-1.0.2
19         >=x11-libs/gtk+-3.22.23:3
20         >=gnome-base/librsvg-2.32.0:2
21 "
22 # libxml2+gdk-pixbuf required for glib-compile-resources (xml-stripblanks and to-pixdata)
23 DEPEND="${RDEPEND}"
24 BDEPEND="
25         dev-libs/libxml2:2
26         dev-util/itstool
27         >=sys-devel/gettext-0.19.8
28         virtual/pkgconfig
29         x11-libs/gdk-pixbuf:2
30         $(vala_depend)
31         media-libs/gsound[vala]
32         gnome-base/librsvg:2[vala]
33 "
34
35 src_prepare() {
36         xdg_src_prepare
37         vala_src_prepare
38 }
39
40 pkg_postinst() {
41         xdg_pkg_postinst
42         gnome2_schemas_update
43 }
44
45 pkg_postrm() {
46         xdg_pkg_postrm
47         gnome2_schemas_update
48 }