dev-qt/qtopengl: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / games-puzzle / gnome-sudoku / gnome-sudoku-3.34.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 VALA_MIN_API_VERSION="0.40"
6
7 inherit gnome.org gnome2-utils meson vala xdg
8
9 DESCRIPTION="Test your logic skills in this number grid puzzle"
10 HOMEPAGE="https://wiki.gnome.org/Apps/Sudoku"
11
12 LICENSE="GPL-3+ CC-BY-SA-3.0"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ~arm64 x86"
15 IUSE=""
16
17 RDEPEND="
18         >=dev-libs/glib-2.40:2
19         dev-libs/libgee:0.8=[introspection]
20         >=x11-libs/gtk+-3.19.0:3[introspection]
21         dev-libs/json-glib
22         >=dev-libs/qqwing-1.3.4
23         x11-libs/gdk-pixbuf:2[introspection]
24         x11-libs/pango[introspection]
25 "
26 DEPEND="${RDEPEND}"
27 BDEPEND="
28         $(vala_depend)
29         dev-libs/appstream-glib
30         dev-util/itstool
31         >=sys-devel/gettext-0.19.8
32         virtual/pkgconfig
33 "
34
35 src_prepare() {
36         xdg_src_prepare
37         vala_src_prepare
38 }
39
40 pkg_postinst() {
41         xdg_pkg_postinst
42         gnome2_schemas_update
43 }
44
45 pkg_postrm() {
46         xdg_pkg_postrm
47         gnome2_schemas_update
48 }