dev-python/virtualenv: keyworded 20.0.21 for ia64, bug #700918
[gentoo.git] / games-puzzle / color-lines / color-lines-0.6-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit desktop
6
7 DESCRIPTION="Color lines game written with SDL with bonus features"
8 HOMEPAGE="https://github.com/OpenA/color-lines-sdl"
9 SRC_URI="https://color-lines.googlecode.com/files/lines_${PV}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86 ~amd64-linux"
14
15 RDEPEND="
16         media-libs/libsdl[X,sound,video]
17         media-libs/sdl-image[png]
18         media-libs/sdl-mixer[wav,mod]
19 "
20 DEPEND="${RDEPEND}"
21
22 S="${WORKDIR}/lines-${PV}"
23
24 src_prepare() {
25         default
26         eapply "${FILESDIR}/${P}-Makefile.patch"
27
28         sed -i \
29                 -e '/^Encoding/d' \
30                 -e '/^Version/d' \
31                 -e '/^Icon/s/.png//' \
32                 color-lines.desktop.in || die 'sed on color-lines.desktop.in failed'
33 }
34
35 src_compile() {
36         emake BINDIR="${EPREFIX}/usr/bin/" GAMEDATADIR="${EPREFIX}/usr/share/${PN}/"
37 }
38
39 src_install() {
40         insinto "/usr/share/${PN}"
41         doins -r gfx sounds
42
43         domenu ${PN}.desktop
44         doicon icon/${PN}.png
45         einstalldocs
46         dobin ${PN}
47 }