kde-plasma/user-manager: x86 stable wrt bug #607680
[gentoo.git] / games-mud / trebuchet / trebuchet-1.075.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit games
8
9 DESCRIPTION="A crossplatform TCL/TK based MUD client"
10 HOMEPAGE="http://belfry.com/fuzzball/trebuchet/"
11 SRC_URI="mirror://sourceforge/trebuchet/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ~ppc x86"
16 IUSE=""
17 RESTRICT="test"
18
19 RDEPEND="
20         >=dev-lang/tk-8.3.3:0=
21         dev-lang/tcl:0="
22
23 src_prepare() {
24         sed -i \
25                 -e "/Nothing/d" \
26                 -e "/LN/ s:../libexec:${GAMES_DATADIR}:" \
27                 Makefile || die
28 }
29
30 src_install() {
31         emake prefix="${D}/${GAMES_PREFIX}" \
32                 ROOT="${D}/${GAMES_DATADIR}/${PN}" install
33
34         insinto "${GAMES_DATADIR}"/${PN}
35         doins COPYING
36         dodoc changes.txt readme.txt trebtodo.txt
37         prepgamesdirs
38 }