net-p2p/gtk-gnutella: x86 stable wrt bug #691324
[gentoo.git] / games-mud / gnome-mud / gnome-mud-9999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 GNOME2_EAUTORECONF="yes"
6
7 inherit gnome2-utils git-r3 meson xdg
8
9 DESCRIPTION="GNOME MUD client"
10 HOMEPAGE="https://wiki.gnome.org/Apps/GnomeMud"
11 SRC_URI=""
12 EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gnome-mud.git"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE="debug gstreamer"
18
19 RDEPEND="
20         >=dev-libs/glib-2.48:2
21         >=x11-libs/gtk+-3.22:3
22         >=x11-libs/vte-0.37:2.91
23         dev-libs/libpcre
24         sys-libs/zlib
25         gstreamer? ( media-libs/gstreamer:1.0 )"
26 DEPEND="${RDEPEND}
27         dev-util/glib-utils
28         >=sys-devel/gettext-0.19.8
29         virtual/pkgconfig"
30
31 src_configure() {
32         local emesonargs=(
33                 -Dmccp=enabled
34                 -Dgstreamer=$(usex gstreamer enabled disabled)
35                 $(meson_use debug debug-logger)
36         )
37         meson_src_configure
38 }
39
40 pkg_postinst() {
41         xdg_pkg_postinst
42         gnome2_icon_cache_update
43         gnome2_schemas_update
44 }
45
46 pkg_postrm() {
47         xdg_pkg_postrm
48         gnome2_icon_cache_update
49         gnome2_schemas_update
50 }