games-mud/gnome-mud: remove deprecated games eclass
[gentoo.git] / games-mud / gmudix / gmudix-1.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit autotools eutils games
7
8 DESCRIPTION="GTK+ MUD client with ANSI color, macros, timers, triggers, variables, and an easy scripting language"
9 HOMEPAGE="http://dw.nl.eu.org/mudix.html"
10 SRC_URI="http://dw.nl.eu.org/gmudix/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86"
15 IUSE=""
16
17 RDEPEND="x11-libs/gtk+:2"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig"
20
21 src_prepare() {
22         epatch "${FILESDIR}"/${P}-as-needed.patch \
23                 "${FILESDIR}"/${P}-format.patch
24         mv configure.in configure.ac || die
25         rm -f missing || die
26         eautoreconf
27 }
28
29 src_install() {
30         dogamesbin src/${PN}
31         dodoc AUTHORS ChangeLog README TODO doc/*txt
32         prepgamesdirs
33 }