games-mud/gnome-mud: remove deprecated games eclass
[gentoo.git] / games-mud / gmudix / gmudix-1.0-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6 inherit autotools eutils
7
8 DESCRIPTION="GTK+ MUD client with ANSI color, macros, timers, triggers, variables, and an easy scripting language"
9 HOMEPAGE="http://dw.nl.eu.org/mudix.html"
10 SRC_URI="http://dw.nl.eu.org/gmudix/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~x86"
15 IUSE=""
16
17 RDEPEND="x11-libs/gtk+:2"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig"
20
21 PATCHES=(
22         "${FILESDIR}"/${P}-as-needed.patch
23         "${FILESDIR}"/${P}-format.patch
24 )
25
26 src_prepare() {
27         default
28
29         mv configure.in configure.ac || die
30         rm -f missing || die
31         eautoreconf
32 }
33
34 src_install() {
35         dobin src/${PN}
36         dodoc AUTHORS ChangeLog README TODO doc/*txt
37 }