Partially revert "games-*/*: Remove stable keywords"
[gentoo.git] / games-misc / xcowsay / xcowsay-1.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="2"
5
6 DESCRIPTION="configurable talking graphical cow (inspired by cowsay)"
7 HOMEPAGE="http://www.doof.me.uk/xcowsay/"
8 SRC_URI="http://www.nickg.me.uk/files/${P}.tar.gz"
9
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="amd64 x86"
13 IUSE="dbus fortune"
14
15 RDEPEND="dbus? ( sys-apps/dbus )
16         dev-libs/dbus-glib
17         fortune? ( games-misc/fortune-mod )
18         media-libs/freetype:2
19         media-libs/libpng
20         x11-libs/pango
21         x11-libs/gtk+:2
22         x11-libs/gdk-pixbuf:2"
23 DEPEND="${RDEPEND}
24         virtual/pkgconfig"
25
26 src_configure() {
27         econf $(use_enable dbus)
28 }
29
30 src_install() {
31         emake DESTDIR="${D}" install || die "emake failed"
32         if ! use fortune; then
33                 rm -f "${D}"/usr/bin/xcowfortune
34         fi
35 }