dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / games-misc / funny-manpages / funny-manpages-1.3_rc5-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils
6
7 MY_R=${PV:0-1}
8 MY_P=${PN}_${PV/_rc?/}
9 DESCRIPTION="funny manpages collected from various sources"
10 HOMEPAGE="https://www.debian.org/"
11 SRC_URI="mirror://debian/pool/main/f/funny-manpages/${MY_P}.orig.tar.gz
12         mirror://debian/pool/main/f/funny-manpages/${MY_P}-${MY_R}.diff.gz"
13
14 LICENSE="freedist" #465704
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~m68k ~mips ~ppc64 ~s390 ~x86"
17 IUSE=""
18
19 RDEPEND="virtual/man"
20
21 S=${WORKDIR}/${MY_P/_/-}.orig
22
23 src_prepare() {
24         epatch ../${MY_P}-${MY_R}.diff
25
26         for f in *.[0-57-9]fun ; do
27                 mv ${f} ${f/.?fun/.6fun} || die "renaming ${f} failed"
28         done
29 }
30
31 src_install() {
32         doman *.6fun
33 }