Merge remote-tracking branch 'remotes/github/pr/115'.
[gentoo.git] / games-fps / ut2004-bonuspack-ece / ut2004-bonuspack-ece-1-r3.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=2
6
7 MOD_DESC="Editor's Choice Edition bonus pack"
8 MOD_NAME="Editor's Choice Edition"
9
10 inherit games games-mods
11
12 MY_P="ut2004megapack-linux.tar.bz2"
13 HOMEPAGE="http://www.unrealtournament2004.com/"
14 SRC_URI="mirror://3dgamers/unrealtourn2k4/Missions/${MY_P}
15         http://0day.icculus.org/ut2004/${MY_P}
16         ftp://ftp.games.skynet.be/pub/misc/${MY_P}
17         http://sonic-lux.net/data/mirror/ut2004/${MY_P}"
18
19 LICENSE="ut2003"
20 KEYWORDS="amd64 x86"
21 IUSE=""
22
23 src_prepare() {
24         mv -f UT2004MegaPack/* . || die
25         rmdir UT2004MegaPack
26
27         rm -r Music Speech
28
29         # Remove megapack files which are not in ece
30         rm Animations/ONSNewTank-A.ukx
31         rm Help/ReadMePatch.int.txt
32         # Help/{DebuggerLogo.bmp,InstallerLogo.bmp,Unreal.ico,UnrealEd.ico}
33         # are not in megapack.
34         # Keep new Help/UT2004Logo.bmp
35         # Manual dir does not exist in megapack
36         rm Maps/{AS*,CTF*,DM*}
37         rm Sounds/A_Announcer_BP2.uax
38         rm StaticMeshes/{JumpShipObjects.usx,Ty_RocketSMeshes.usx}
39         rm System/{A*,b*,B*,CacheRecords.ucl}
40         rm System/{*.det,*.est,*.frt,*.itt,*.kot}
41         rm System/{CTF*,D*,Editor*,G*,I*,L*,ONS-Arc*,Onslaught.*,*.md5}
42         rm System/{u*,U*,V*,X*,Core.u,Engine.u,F*,*.ucl,Sk*}
43         rm Textures/{J*,j*,T*}
44         rm -r Web
45
46         # The file lists of ut2004-3369-r1 and -r2 are identical
47         # Remove files owned by ut2004-3369-r2
48         rm Help/UT2004Logo.bmp
49         # The 2 Manifest files have not changed
50         rm System/{Manifest.in{i,t},OnslaughtFull.int}
51         rm System/{Core.int,Engine.int,Setup.int,Window.int}
52         rm System/{OnslaughtFull.u,OnslaughtBP.u}
53 }