games-fps/quake2-data: update homepage
[gentoo.git] / games-fps / quake1-rally / quake1-rally-1.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils games
6
7 DESCRIPTION="TC which turns Quake into a Rally racing game"
8 HOMEPAGE="http://wiki.quakeworld.nu/Quake_Rally"
9 SRC_URI="http://ehall.freeshell.org/quake/qr12.zip
10         http://ehall.freeshell.org/quake/qrlo1.zip"
11
12 LICENSE="all-rights-reserved"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16 RESTRICT="mirror bindist"
17
18 RDEPEND=""
19 DEPEND="app-arch/unzip"
20
21 S=${WORKDIR}
22
23 src_unpack() {
24         echo ">>> Unpacking qr12.zip to ${PWD}"
25         unzip -qoLL "${DISTDIR}"/qr12.zip || die "unpacking qr12.zip failed"
26         echo ">>> Unpacking qrlo1.zip to ${PWD}"
27         unzip -qoLL "${DISTDIR}"/qrlo1.zip || die "unpacking qrlo1.zip failed"
28         rm -f button.wav qrally.exe
29         cd rally
30         edos2unix $(find . -name '*.txt' -o -name '*.cfg')
31         mv rally{,.example}.cfg
32 }
33
34 src_install() {
35         insinto "${GAMES_DATADIR}/quake1"
36         doins -r *
37         prepgamesdirs
38 }