dev-util/lldb: Reorder ebuild vars in 9+
[gentoo.git] / games-fps / duke3d-demodata / duke3d-demodata-1.3.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit games
7
8 DESCRIPTION="Duke Nukem 3D 1.3d shareware data"
9 HOMEPAGE="http://www.3drealms.com/duke3d/"
10 SRC_URI="ftp://ftp.3drealms.com/share/3dduke13.zip"
11
12 LICENSE="DUKE3D"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="app-arch/unzip"
18 RDEPEND="games-fps/eduke32"
19
20 S=${WORKDIR}
21
22 src_unpack() {
23         default
24         rm LICENSE.TXT || die
25         mv DN3DSW13.SHR DN3DSW13.SHR.zip || die
26         unpack ./DN3DSW13.SHR.zip
27 }
28
29 src_install() {
30         insinto "${GAMES_DATADIR}"/duke3d
31
32         # convert to lowercase
33         find . \( -iname "*.CON" -o -iname "*.DMO" -o -iname "*.RTS" -o -iname "*.GRP" -o -iname "*.PCK" -o -iname "*.INI" \) \
34                 -exec sh -c 'echo "${1}"
35         mv "${1}" "$(echo "${1}" | tr [:upper:] [:lower:])"' - {} \;
36
37         doins {defs,game,user}.con demo{1,2,3}.dmo duke.rts duke3d.grp modem.pck ultramid.ini
38
39         dodoc FILE_ID.DIZ README.DOC
40
41         prepgamesdirs
42 }
43
44 pkg_postinst() {
45         games_pkg_postinst
46         echo
47         einfo "Please note that many addons for Duke Nukem 3D require the registered version"
48         einfo "and will not work with this shareware version."
49         echo
50 }