games-fps/eduke32: fix timidity deps
[gentoo.git] / games-fps / doom3-hellcampaign / doom3-hellcampaign-1-r1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 MOD_DESC="map pack for Doom 3"
7 MOD_NAME="Hell Campaign"
8 MOD_DIR="hell_campaign"
9
10 inherit games games-mods
11
12 HOMEPAGE="http://www.gamefront.com/files/listing/gamingfiles/Doom_III/Maps/Map_Packs/"
13 SRC_URI="sp_hc_final.zip
14         hardcorehellcampaign_patch.zip"
15
16 LICENSE="GameFront"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="dedicated opengl"
19 RESTRICT="fetch bindist"
20
21 pkg_nofetch() {
22         elog "Please download the following files:"
23         elog "http://www.filefront.com/4445166"
24         elog "http://www.filefront.com/4593578"
25         elog "and move them to your DISTDIR directory."
26 }
27
28 src_unpack() {
29         mkdir ${MOD_DIR}
30         cd ${MOD_DIR}
31         unpack ${A}
32 }
33
34 src_prepare() {
35         cd ${MOD_DIR}
36
37         # Prevent "non-portable" upper-case-filename warnings in Doom 3
38         mv -f "Hardcore Hell Campaign.pk4" hardcore_hell_campaign.pk4 || die
39         mv -f Q2Textures.pk4 q2Textures.pk4 || die
40         mv -f Q3Textures.pk4 q3Textures.pk4 || die
41
42         mv -f "Hardcore Hell Campaign.rtf" readme.rtf || die
43
44         # Show nice description in "mods" menu within Doom 3
45         echo "${MOD_NAME}" > description.txt
46 }